CentOS7.4下离线安装python3.6.1所需依赖包整理!

2018年10月20日 0条评论 2836点热度 0人点赞 阅读全文

centos 7.4下安装python3.6.1后,程序调用新版本python的两种设置方法:1、配置python虚拟环境,在其中运行程序。2、修改系统默认Python版本为3.6.1,直接运行python3程序。以及介绍centos7.4下修改python默认版本后,yum和firewalld等程序不能使用的解决方法!

2018年10月20日 0条评论 1863点热度 0人点赞 阅读全文

  在使用自动化运维工具ansible来管理服务器的时候,,一些比较老的机器可能因为系统自带的python版本较低(2.6之前),缺少ansible依赖的Simplejson模块。导致无法正常管理该服务器。这种情况下我们有两种方法去解决它:1.额外在单独安装Simplejson模块。 2.升级python版本至2.6及以上版本。这里我们记录下升级python版本的方法。 一、安装依赖包 [crayon-5f69bbbc550f1843234004/] 一定要提前安装好zlib-devel包,然后…

2018年10月16日 0条评论 1855点热度 0人点赞 阅读全文

修改了之前编写的根据文件中定义主机列表批量获取服务器磁盘使用情况脚本,获取到远程服务器磁盘使用信息后生成指定格式的html文件。然后调用python脚本发送html格式邮件到指定邮箱!

2018年10月10日 0条评论 1236点热度 0人点赞 阅读全文