在使用自动化运维工具ansible来管理服务器的时候,,一些比较老的机器可能因为系统自带的python版本较低(2.6之前),缺少ansible依赖的Simplejson模块。导致无法正常管理该服务器。这种情况下我们有两种方法去解决它:1.额外在单独安装Simplejson模块。 2.升级python版本至2.6及以上版本。这里我们记录下升级python版本的方法。 一、安装依赖包 [crayon-5f03a9ae7b0c0924160274/] 一定要提前安装好zlib-devel包,然后…

2018年10月16日 0条评论 1713点热度 0人点赞 阅读全文

讲下在服务器不能连外网的情况下,怎么解决依赖关系正常安装需要的软件包。主要就三点:1、虚拟机中安装和服务器一致的系统版本做测试环境(纯净系统)。2、修改yum配置文件,开启安装包缓存。3、在该测试环境中使用yum安装需要的软件包,并搜集yum缓存中所有包装宝即可。

2018年06月18日 0条评论 4401点热度 2人点赞 阅读全文

linux下使用光盘中自带的rpm软件包,配置本地yum源。

2017年05月07日 0条评论 2686点热度 0人点赞 阅读全文